If resto druids get to see our armor…

Can they at least make the armor not buggy?

Okay, so today I just have a short update on a couple of things. At this point, my druid has been able to start running heroics. I’ve mostly run stuff as DPS, but I’ve solo-healed a couple of heroic bosses. I haven’t been able to run many heroics just because my pre-holiday schedule has been so hectic.

However, since I’ve been running heroics in a healer-heavy guild, it sometimes ends up working out such that we’ve 2-healed some of the heroic bosses. As several other bloggers have pointed out, the bosses don’t have real enrage timers, so having 2 healers (when we’re still undergeared for the content) turned out to be better than one. Too bad you can’t queue for double-healer PUGs. Anyway, back to the point of today’s story.

If I’m running around as resto, there is one thing that bugs me a lot, the fact that the graphic for my dress bugs out on me all the time. When I’m moonkin, I just don’t see my robe often enough to be bothered by the problem.

Here is what it is supposed to look like:

Sure, it’s a little bit drab overall, but I can live with ‘drab’. However, the vast majority of the time, it doesn’t look like that. I only get that graphic for a short period of time after I unequip and re-equip my robe. The rest of the time, it has an ugly flesh-colored band around my knees, where my skin has managed to bleed through to the outside of the graphic’s fabric and made it look super ugly, like this:

By the time they fix this bug, I’ll probably have a different chest piece (that hopefully won’t also bug out). It looks like there is a problem with the texture (and not just my computer) because it will show up with the bugged graphic on my loading screen & the armory. After I get the “right” graphic to show up, the “bugged” graphic shows up when I shapeshift, as in it’s not retaining the right texture/graphic once I’ve shifted in & out of any form. However, it looks like since my pants share the graphic with the chest piece, my pants graphic may be compensating some for the bugged chest graphic. I guess my Cursed Skardyn Vest really is cursed. Robes of the Loving Ursine have the same problem for me, since they share a graphic. I’m wearing them with Leggings of the Path. Is anyone else having a similar problem? The heroic versions of these items would still have the same graphic.

In other news, our first Team Waffle Podcast was recorded on Friday. Arielle (from Death Kitty) is currently working on editing. I guess that the main recording we were using cut out in a couple places, so he’s having to try and splice the backup copies we made to get it right.

This entry was posted in 4.0.3a, Cataclysm. Bookmark the permalink. Both comments and trackbacks are currently closed.

15 Comments

  1. Posted December 19, 2010 at 11:26 am | Permalink

    That’s an interesting bug…you should put in a ticket.

    • Lissanna
      Posted December 19, 2010 at 11:30 am | Permalink

      I posted on the bug report forums. It’s not impacting gameplay enough to bug GMs about it.

      Also, if I take off my pants when my skin is peaking through like that, I actually get one giant uni-leg (ie. the shape of the skirt, but colored like legs all the way down) that is really, really nasty looking (that I wouldn’t want to post up here ’cause it would scare small children, lol).

      • Galardris
        Posted December 19, 2010 at 12:15 pm | Permalink

        I wore leggings of the path and that flesh colored band drove me nuts. I changed to the rep pants from earthen ring revered and now I have pants that look nice again. I was wearing the justice point chest though, not the same chest as you.

        • Lissanna
          Posted December 19, 2010 at 12:49 pm | Permalink

          Yeah, I think it’s just everything with that texture on it (pants or chest). I have the unfortunate situation of really, really needing to buy a new chest piece to cover it all. ;)

  2. Siobhann
    Posted December 19, 2010 at 12:08 pm | Permalink

    I get that bug too. I usually switch to my feral gear and back and it goes away. The pants are ugly anyway. They look to me like the texture is messed up past the knees whether or not the flesh-colored stripe appears.

  3. Deandre - Dalaran
    Posted December 19, 2010 at 12:17 pm | Permalink

    Very first thought I had when I saw what it’s doing with your leg texture there, “It puts the lotion on it’s skin or it gets the hose again.”

    • Lissanna
      Posted December 19, 2010 at 2:39 pm | Permalink

      Oh, it gets so much worse. Here’s the full bugged graphic that I didn’t originally post ’cause it’s too nasty…
      http://img51.imageshack.us/img51/3735/wowscrnshot121910125249.jpg
      If I get it to bug and then take off the pants (leaving the chest piece on), it totally freaks out and bugs out from the waist-down, and I have one Uni-leg that’s super disgusting.

      • Deandre - Dalaran
        Posted December 19, 2010 at 4:24 pm | Permalink

        If I remember correctly, it used to do that rarely back in the day with the Judgement kilt. I went through a whole raid on my Paladin with it like that just to freak out other healers.

  4. Posted December 20, 2010 at 12:10 am | Permalink

    Actuallly, I’ve had a similar bug with my shoulders.

    For some reason, they just don’t want to load upon logging in or porting into a zone.

    Essentially, I have to UNequip them, and then RE-equip them, and they reappear. It’s interesting.

    So back to the other thing you said: 2 healing dungeons while weak on gear? I seriously never thought of that…I might bring that up, whilst I’m still trying to get the gearz…

    Because let me ask you this:

    Why, seriously DEAR GAWD WHY, do I have to grind Dragonmaw rep to get an epic piece of gear, when Hyjal…which is nothing but a bunch of druids, has nothing for, you know, druids. They have a cloth piece, strength back, mail and plate…but no druid-friendly gear (epic that is, they have ONE piece at revered for a resto druid).

    What kind of sense does that make? In Wrath, the rep you grinded first seemed to make sense. If you were a clothie dpser, Kirin Tor was your first stop. If you were a dps plate wearer, Ebon Blade, Tank plate went with Argent Crusade, mail wearers went with Wyrmrest…but that does not seem to go with Cata and for me, it just doesn’t make sense.

    Ah well…off to do my Tol Barad dailies…halfway on the badges to get that awesome drake mount!

    • Posted December 20, 2010 at 7:06 am | Permalink

      Yeah, the whole rep situation is really irking me too. Not only that, but there aren’t any grinds for the completionists out there. I wrote a super long entry about it… I was really looking forward to some long, obscure reps with cool rewards and there really aren’t any.

  5. Posted December 20, 2010 at 3:46 am | Permalink

    I’m wearing Leggings of the Lost Child (http://www.wowhead.com/item=66894) with Wrap of the Fallen City (http://www.wowhead.com/item=65741) which seem to have the same texture, and I haven’t seen this bug. Maybe it’s just a couple of particular items?

    Actually, I just looked at yours in 3D on wowhead, and they’re *still* bugged. My chest piece is a tunic, so on wowhead I see a night elf in a tunic and bikinis. Your chest pieces are robes, so I see… a night elf in a tunic and a flesh-colored skirt. My guess is that they’re meant to be tunics too, but they fucked up the bottom part.

  6. Tala
    Posted December 20, 2010 at 12:14 pm | Permalink

    I thought my skirt looked odd with a white stripe…

    My night elf is luckily very pale, so it doesn’t look quite as awful, but I’m having the same problem with different gear. I’m wearing Vest of the Curious Visitor (http://us.battle.net/wow/en/item/63471) and Blazewing’s Furious Kilt (http://us.battle.net/wow/en/item/63471).

  7. Onomaris
    Posted December 21, 2010 at 1:17 pm | Permalink

    I have this same bug so I feel your pain. I think it’s even more disturbing on a Tauren. There’s something so wrong about me wearing a skirt made out of my own cow hide.

  8. Posted December 29, 2010 at 5:42 am | Permalink

    I got that all the time :( Didn’t realise it was a bug until now though haha. I guess I have been too busy looknig at other things xD

  9. Edeslash
    Posted December 29, 2010 at 4:06 pm | Permalink

    I didn’t even know it’s a bug! I have the same problem and it really looks horrible…